Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#541 closed task (fixed)

Update dependencies

Reported by: Twan Goosen Owned by:
Priority: major Milestone: VLO-3.1
Component: VLO web app Version:
Keywords: Cc:

Description

At the time of writing this ticket (2014/4/28), the following newer versions are available (when snapshot is mentioned, it's available - update as soon as stable is available):

Shared

Solr: 4.7.2
Saxon: 9.5.1-5
SLF4J: 1.7.7

Web app

Spring: 3.2.8
Jersey Client: 1.18.1
Apache Commons Lang3: 3.3.2 (3.4-SNAPSHOT)
Wicket: 6.15-SNAPSHOT

Importer

commons-lang: 2.6 (2.7-SNAPSHOT)
vtd-xml: 2.11

Change History (5)

comment:1 Changed 10 years ago by Twan Goosen

Component: AAIVLO web app
Milestone: VLO-3.1
Type: defecttask

Oops, wrong component

comment:2 Changed 10 years ago by Twan Goosen

Updated dependencies for all mentioned libraries except for VTD-XML in r5116

comment:3 Changed 10 years ago by Twan Goosen

Solr 4.8.0 is available (see https://lucene.apache.org/solr/solrnews.html). It requires Java 7, which strikes me as a good thing but I will need to check whether this is ok with all deployment platforms and development environments.

In any case, the application seems to build and run fine with 4.8.0 (in a Java 7 environment).

comment:4 Changed 10 years ago by Twan Goosen

Resolution: fixed
Status: newclosed

Created follow-up for VTD-XML: #549

comment:5 Changed 9 years ago by Twan Goosen

More dependency updates in r5988, most importantly:

  • Wicket -> 6.19.0
  • Spring -> 3.2.13
  • Jersey client -> 1.18.3
  • Guava -> 1.18
  • SLF4J-> 1.7.10
Version 0, edited 9 years ago by Twan Goosen (next)
Note: See TracTickets for help on using tickets.