Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#542 closed defect (fixed)

Wrong value passed to aggregator for record handle

Reported by: Twan Goosen Owned by:
Priority: blocker Milestone: VLO-3.0
Component: VLO web app Version:
Keywords: Cc: teckart@informatik.uni-leipzig.de

Description (last modified by Twan Goosen)

Florian Schiel? reported:

URL:
http://catalog-clarin.esc.rzg.mpg.de/vlo/record?fq=resourceClass:audio&fq=collection:Bavarian+Archive+for+Speech+Signals+%28BAS%29&docId=hdl_58_11858_47_00-1779-0000-001A-1C5D-1_64_format_61_cmdi
Issue description:
Something seems to be wrong with the pass to FCS:
The links to FCS appear in resource pages (only) that support FCS in their
CMDI record, but the link opens the FCS without selecting the resource. I
tested it with 'ALC' and 'HAMATAC'.

The cause seems to be that the VLO does not send the record handle to the Aggregator, but instead sends the docId - which is never a valid handle URI. Compare:

VLO 2.18:

 {"https://clarin.phonetik.uni-muenchen.de/BASSRU/": ["hdl:11858/00-1779-0000-001A-1C5D-1@format=cmdi"]}
{"http://cqlservlet.mpi.nl/": ["hdl:1839/00-0000-0000-0001-53A7-1@format=cmdi"]}

VLO 3.0-beta:

 {"https://clarin.phonetik.uni-muenchen.de/BASSRU/": ["hdl_58_11858_47_00-1779-0000-001A-1C5D-1_64_format_61_cmdi"]}

The VLO should always send the handle (is it available at the moment? investigate)

Change History (5)

comment:1 Changed 10 years ago by DefaultCC Plugin

Cc: teckart@informatik.uni-leipzig.de added

comment:2 Changed 10 years ago by Twan Goosen

This was caused by the changes for #490 (on my request, I admit it ;)). The cleanest solution is to add a field 'selfLink' which holds the original, actual self link (which is the source of the doc ID if it is present) and use this field to populate the JSON request to the aggregator.

comment:3 Changed 10 years ago by Twan Goosen

Added the field _selfLink to Solr and importer in r5091

comment:4 Changed 10 years ago by Twan Goosen

Resolution: fixed
Status: newclosed

Fixed in #5093

Version 1, edited 10 years ago by Twan Goosen (previous) (next) (diff)

comment:5 Changed 10 years ago by Twan Goosen

Description: modified (diff)

Merged to VLO-3.0 branch in r5094

Note: See TracTickets for help on using tickets.